Plot the Australian coastline and states

Plot the Australian coastline and states [R logo]

Help pages for package `oz' version 1.0-15

nsw | Plot specific Austrialian states
nt | Plot specific Austrialian states
oz | Plot the Australian coastline and states
ozRegion | Plot the Australian coastline and states
qld | Plot specific Austrialian states
sa | Plot specific Austrialian states
tas | Plot specific Austrialian states
vic | Plot specific Austrialian states
wa | Plot specific Austrialian states


Plot the Australian coastline and states

Description

Plot the Australian coastline and states.

Usage

oz(states = TRUE, coast = TRUE, xlim = NULL,
   ylim = NULL, add = FALSE, ar = 1, eps = 0.25,
   sections = NULL, visible = NULL, ...)

ozRegion(states = TRUE, coast = TRUE, xlim = NULL,
         ylim = NULL, eps = 0.25,
         sections = NULL, visible = NULL)

Arguments

states | logical flag: include mainland internal state boundaries?
coast | logical flag: include coastline?
xlim | optional limits for the x-axis (longitude).
ylim | optional limits for the y-axis (latitude). (N.B. all latitudes for Australia are south, and hence are NEGATIVE.)
add | logical flag. If TRUE, the plot is superimposed on an existing plot. Otherwise, a new plot is generated.
ar | aspect ratio: longitude to latitude.
eps | If sections (q.v.) is specified explicitly, the plot is enlarged four ways by this amount (degrees).
sections | integer vector specifying which sections of the plot are to be included in the range calculation. The sections are as follows: 1-7, coastlines of WA(1), NT(2), QLD(3), NSW(4), VIC(5), TAS(6) and SA(7) respectively; sections 8-16 are internal mainland state boundaries: SA-WA(8), WA-NT(9), NT-SA(10), NT-QLD(11), QLD-SA(12), QLD-NSW(13), NSW-SA(14), NSW-VIC(15), VIC-SA(16).
visible | integer vector specifying which of the sections are actually to appear on the plot.
... | optional arguments which will be passed through lines.

Graphical parameters (see par()) may also be supplied as arguments to this function.

Value

ozRegion returns an object of class "ozRegion", which is a list with the following elements: rangex and rangey, giving the range of values to be plotted; and lines, a list of lists, where each sub-list describes a line to draw via numeric elements x and y.

Examples

oz()                    # the lot
oz(states=FALSE)        # coastlines only
oz(sections=6)          # Tasmania
oz(sections=c(7,8,10,12,14,16))         # South Australia
oz(sections=c(3,11:13), visible=c(3,13))# plot Queensland, but show just
                                        # coast and border with NSW.
[Package oz version 1.0-15 Index]


Internal oz objects

Description

Internal oz objects.

Usage

.Oz.cities
.Oz.limits
.Oz.sections

Details

These are not to be called by the user.

[Package oz version 1.0-15 Index]


Plot specific Austrialian states

Description

Plot the named Australian state along with its coastline.

Usage

nsw(...)
nt(...)
qld(...)
sa(...)
tas(...)
vic(...)
wa(...)

Arguments

... arguments to be passed on to oz.
[Package oz version 1.0-15 Index]