Draw Geographical Maps

Draw Geographical Maps [R logo]

Help pages for package `maps' version 2.0-35

area.map | Area of projected map regions
canada.cities | Database of Canadian cities
county | United States County Map
countyMapEnv | United States County Map
france | France Map
franceMapEnv | France Map
identify.map | Identify regions on a map
italy | Italy Map
italyMapEnv | Italy Map
map | Draw Geographical Maps
map.axes | Draw Axes on Geographical Maps
map.cities | Add Cities to Existing Map
map.scale | Add Scale to Existing Unprojected Map
map.text | Draw a map with labeled regions
map.where | Locate points on a map
match.map | Index map regions
nz | New Zealand Basic Map
nzMapEnv | New Zealand Basic Map
ozone | Sample datasets
smooth.map | Smooth out aggregated data
state | United States State Boundaries Map
stateMapEnv | United States State Boundaries Map
us.cities | Database of US cities
usa | United States Coast Map
usaMapEnv | United States Coast Map
votes.repub | Sample datasets
world | Low resolution World Map
world.cities | Database of world cities
world2 | Pacific Centric Low resolution World Map
world2MapEnv | Pacific Centric Low resolution World Map
worldMapEnv | Low resolution World Map


Area of projected map regions

Description

Computes the areas of regions in a projected map.

Usage

area.map(m, regions = ".", sqmi=TRUE, ...)

Arguments

m | a map object containing named polygons (created with fill = TRUE).
regions | a character vector naming one of more regions, as in map.
sqmi | If TRUE, measure area in square miles. Otherwise keep the units of m.
... | additional arguments to match.map

Details

The area of each matching region in the map is computed, and regions which match the same element of regions have their areas combined. Each region is assumed planar, with vertices specified by the x and y components of the map object.

The correct use of this function is to first use map to create polygons and project the coordinates onto a plane, then apply area.map to compute the area of the projected regions. If the projection is area-preserving (such as albers), then these areas will match the area on the globe, up to a constant. To get an absolute area in square miles, the sqmi option will scale the result, depending on the projection.

The coordinates from map are affected by its resolution argument, so use resolution=0 for the most accurate areas.

Value

a named vector of region areas.

NOTE

The sqmi option assumes the coordinates have been projected with the mapproject function.

Author(s)

Tom Minka

See Also

area.polygon, apply.polygon

Examples

# because the projection is rectangular, these are not true areas on the globe.
m = map("state", fill = TRUE, plot = FALSE)
area.map(m)
area.map(m, ".*dakota")
area.map(m, c("North Dakota", "South Dakota"))

if(require(mapproj)) {
  # true areas on the globe
  m = map("state", proj="bonne", param=45, fill=TRUE, plot=FALSE)
  # North Dakota is listed as 70,704 square miles
  area.map(m, "North Dakota")
}
[Package maps version 2.0-35 Index]


Database of Canadian cities

Description

This database is of Canadian cities of population greater than about 1,000. Also included are province capitals of any population size.

Format

A list with 6 components, namely "name", "country.etc", "pop", "lat", "long", and "capital", containing the city name, the province abbreviation, approximate population (as at January 2006), latitude, longitude and capital status indication (0 for non-capital, 1 for capital, 2 for provincial

capital.

NOTE

Some of the city names may be out of date. Please send any corrections to the package maintainer.

See Also

map.cities


United States County Map

Description

This database produces a map of the counties of the United States mainland generated from US Department of the Census data (see the reference).

Usage

data(countyMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

US Department of Commerce, Census Bureau, County Boundary File, computer tape, available from Customer Services, Bureau of the Census, Washingdon DC 20233.

See Also

map.

Examples

map('county', 'iowa', fill = TRUE, col = palette())


France Map

Description

This france database comes from the NUTS III (Tertiary Administrative Units of the European Community) database of the United Nations Environment Programme (UNEP) GRID-Geneva data sets. These were prepared around 1989, and so may be somewhat out of date.

Users of data sets supplied through UNEP/GRID are requested to incorporate in output products and reports acknowledgements to the originator of the data and to the fact that they were acquired through UNEP/GRID. Appropriate wording may be "UNESCO (1987) through UNEP/GRID-Geneva".

Usage

data(franceMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

See Also

map

Examples

map('france', fill = TRUE, col = 1:10)


Identify regions on a map

Description

Identifies the map regions clicked by the user.

Usage

## S3 method for class 'map':
identify(x, n = 1, index = FALSE, ...)

Arguments

x | a map object containing named polygons.
n | the number of clicks to wait for.
index | If TRUE, returns the index of the polygon, rather than its name.
... | additional arguments passed to identify.default.

Details

The current algorithm is somewhat crude — selects the region whose centroid is closest to the click. A more sophisticated approach would use map.where.

Value

a character vector of length n, naming the selected regions.

Author(s)

Tom Minka

See Also

identify, map.where

Examples

identify(map("state", fill = TRUE, col = 0))
if(require(mapproj))
  identify(map("world", proj = "lagrange", fill = TRUE, col = 0))


Internally Required Functions

Description

These functions are called internally and will generally not be required by the user.

Usage

makepoly(xy, gonsize, keep)
mapgetg(database, gons, fill, xlim, ylim)
mapgetl(database, lines, xlim, ylim, fill)
mapname(database, patterns, exact)
mapthin(xy, delta, symmetric)
maptype(database)


Internally Required Functions

Description

These functions are called internally and will generally not be required by the user.

Usage

char.to.ascii(s)
is.regexp(s)
indicators.factor(y)
insert(x, i, v)
match.map.slow(nam, regions, warn = FALSE)
match.map.grep(nam, regions, warn = FALSE)
map.old(database = "state", regions = ".", exact = F, boundary = T,
    interior = T, fill = F, projection = "", parameters = NULL,
    orientation = rep(NA, 3), color = 1, add = F, plot = T, namesonly = F,
    xlim = c(-1e+30, 1e+30), ylim = c(-1e+30, 1e+30), resolution = 1,
    type = "l", ...)
map.poly(database, regions = ".", exact = FALSE, xlim = NULL, ylim = NULL,
         boundary = TRUE, interior = TRUE, fill = FALSE, as.polygon = FALSE)
map.wrap(p)
subgroup(x, i)
gp.smooth(x, z, xo, lambda, r)
kernel.smooth(x, z, xo, lambda, region = NULL, normalize = TRUE)
kernel.region.region(x, region, lambda)
kernel.region.x(x, region, z, lambda)


Italy Map

Description

This italy database comes from the NUTS III (Tertiary Administrative Units of the European Community) database of the United Nations Environment Programme (UNEP) GRID-Geneva data sets. These were prepared around 1989, and so may be somewhat out of date.

Users of data sets supplied through UNEP/GRID are requested to incorporate in output products and reports acknowledgements to the originator of the data and to the fact that they were acquired through UNEP/GRID. Appropriate wording may be "UNESCO (1987) through UNEP/GRID-Geneva".

Usage

data(italyMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

See Also

map

Examples

map('italy', fill = TRUE, col = 1:10)


Draw Geographical Maps

Description

Draw lines and polygons as specified by a map database.

Usage

map(database, regions)  # simple form
map(database = "world", regions = ".", exact = FALSE, boundary = TRUE,
  interior = TRUE, projection = "", parameters = NULL, orientation = NULL,
  fill = FALSE, col = 1, plot = TRUE, add = FALSE, namesonly = FALSE,
  xlim = NULL, ylim = NULL, wrap = FALSE, resolution = if(plot) 1 else 0,
  type = "l", bg = par("bg"), mar = c(0, 0, par("mar")[3], 0.1),
  border = 0.01, ...)

Arguments

database | character string naming a geographical database, or a list of x, y, and names obtained from a previous call to map. The string choices include a world map, three USA databases (usa, state, county), and more (see the package index). The location of the map databases may be overridden by setting the R_MAP_DATA_DIR environment variable. See world for further details.
regions | character vector that names the polygons to draw. Each database is composed of a collection of polygons, and each polygon has a unique name. When a region is composed of more than one polygon, the individual polygons have the name of the region, followed by a colon and a qualifier, as in michigan:north and michigan:south. Each element of regions is matched against the polygon names in the database and, according to exact, a subset is selected for drawing. The default selects all polygons in the database.
exact | If TRUE, only exact matches with regions are selected for drawing. If FALSE, each element of regions is matched as a regular expression against the polygon names in the database and all matches are selected for drawing.
boundary | If FALSE, boundary segments are not drawn. A boundary segment is a line segment of the map that bounds only one of the polygons to be drawn. This argument is ignored if fill is TRUE.
interior | If FALSE, interior segments are not drawn. An interior segment is a line segment of the map that bounds two of the polygons to be drawn. This argument is ignored if fill is TRUE.
projection | character string that names a map projection to use. See mapproject (in the mapproj library). The default is to use a rectangular projection with the aspect ratio chosen so that longitude and latitude scales are equivalent at the center of the picture.
parameters | numeric vector of parameters for use with the projection argument. This argument is optional only in the sense that certain projections do not require additional parameters. If a projection does require additional parameters, these must be given in the parameters argument.
orientation | a vector c(latitude, longitude, rotation) describing where the map should be centered and a clockwise rotation (in degrees) about this center.
fill | logical flag that says whether to draw lines or fill areas. If FALSE, the lines bounding each region will be drawn (but only once, for interior lines). If TRUE, each region will be filled using colors from the col = argument, and bounding lines will not be drawn.
col | vector of colors. If fill is FALSE, the first color is used for plotting all lines, and any other colors are ignored. Otherwise, the colors are matched one-one with the polygons that get selected by the region argument (and are reused cyclically, if necessary). A color of NA causes the corresponding region to be deleted from the list of polygons to be drawn. Polygon colors are assigned after polygons are deleted due to values of the xlim and ylim arguments.
plot | logical flag that specifies whether plotting should be done. If plot is TRUE the return value of map will not be printed automatically .
add | logical flag that specifies whether to add to the current plot. If FALSE, a new plot is begun, and a new coordinate system is set up.
namesonly | If TRUE, the return value will be a character vector of the names of the selected polygons. See the Value section below.
xlim | two element numeric vector giving a range of longitudes, expressed in degreees, to which drawing should be restricted. Longitude is measured in degrees east of Greenwich, so that, in particular, locations in the USA have negative longitude. If fill = TRUE, polygons selected by region must be entirely inside the xlim range. The default value of this argument spans the entire longitude range of the database.
ylim | two element numeric vector giving a range of latitudes, expressed in degrees, to which drawing should be restricted. Latitude is measured in degrees north of the equator, so that, in particular, locations in the USA have positive latitude. If fill = TRUE, polygons selected by region must be entirely inside the ylim range. The default value of this argument spans the entire latitude range of the database.
wrap | If TRUE, lines that cross too far across the map (due to a strange projection) are omitted.
resolution | number that specifies the resolution with which to draw the map. Resolution 0 is the full resolution of the database. Otherwise, just before polylines are plotted they are thinned: roughly speaking, successive points on the polyline that are within resolution device pixels of one another are collapsed to a single point (see the Reference for further details).
type | character string that controls drawing of the map. Aside from the default type = "l", the value type = "n" can be used to set up the coordinate system and projection for a map that will be added to in later calls.
bg | background color.
mar | margins, as in par.
border | scalar or vector of length 2 specifying the porportion of the plot to add to the defined or computed limits as borders.
... | Extra arguments passed to polygon or lines.

Value

If plot = TRUE, a plot is made where the polygons selected from database, through the regions, xlim, and ylim arguments, are outlined (fill is FALSE) or filled (fill is TRUE) with the colors in col.
The return value is a list with x, y, range, and names components. This object can be used as a database for successive calls to map and functions. If fill is FALSE, the x and y vectors are the coordinates of successive polylines, separated by NAs. If fill is TRUE, the x and y vectors have coordinates of successive polygons, again separated by NAs. Thus the return value can be handed directly to lines or polygon, as appropriate.
When namesonly is TRUE, only the names component is returned.
After a call to map for which the projection argument was specified there will be a global variable .Last.projection containing information about the projection used. This will be consulted in subsequent calls to map which use projection = ''.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993. http://public.research.att.com/areas/stat/doc/93.2.ps

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995. http://public.research.att.com/areas/stat/doc/95.2.ps

See Also

map.text, map.axes, map.scale, map.grid (in the mapproj library)

Examples

map()   # low resolution map of the world
map('usa')      # national boundaries
map('county', 'new jersey')     # county map of New Jersey
map('state', region = c('new york', 'new jersey', 'penn'))      # map of three states
map("state", ".*dakota", border = 0)    # map of the dakotas
map.axes()                              # show the effect of border = 0
if(require(mapproj))
  map('state', proj = 'bonne', param = 45)      # Bonne equal-area projection of states

# names of the San Juan islands in Washington state
map('county', 'washington,san', names = TRUE, plot = FALSE)

# national boundaries in one linetype, states in another
# (figure 5 in the reference)
map("state", interior = FALSE)
map("state", boundary = FALSE, lty = 2, add = TRUE)

# plot the ozone data on a base map
# (figure 4 in the reference)
data(ozone)
map("state", xlim = range(ozone$x), ylim = range(ozone$y))
text(ozone$x, ozone$y, ozone$median)
box()


Draw Axes on Geographical Maps

Description

Draws a set of axes on an existing map.

Usage

map.axes()

Details

Side Effects

x- and y-axes are drawn for the currently displayed map. These will display in longitude and latitude (if no projection= has been specified in the map() call).

Examples

map("state")
map.axes()


Add Cities to Existing Map

Description

Adds city locations and (optionally) names to an existing map using a specified database.

Usage

map.cities(x = world.cities, country = "", label = NULL, minpop = 0,
maxpop = Inf, capitals = 0, cex = par("cex"), projection = FALSE,
parameters = NULL, orientation = NULL, ...)

Arguments

x | Name of database. See world.cities to determine the structure of the database.
country | If the string country is specified, limit the displayed cities to be from within the specified country, province or state (depending on how the database has been constructed).
label | If TRUE, label all cities. If NULL, the cities will be labelled unless there are 20 or more.
minpop | The minimum value of population below which a particular city will not be shown.
maxpop | The maximum value of population above which a particular city will not be shown.
capitals | Selection of capitals-only display. Capitals may be 1 (country capital), 2 (provincial, state, or regional capital) or 3 (local capital). See world.cities for further information.
cex | The value of cex acts to override the current value of character size expansion.
projection | Boolean or character value. If FALSE (the default), no projection is assumed, if TRUE, the previous projection is used, otherwise a character string that names a map projection to use. See mapproject (in the mapproj library).
parameters | numeric vector of parameters for use with the projection argument. This argument is optional only in the sense that certain projections do not require additional parameters. If a projection does require additional parameters, these must be given in the parameters argument.
orientation | a vector c(latitude, longitude, rotation) describing where the map should be centered and a clockwise rotation (in degrees) about this center.
... | Further plotting parameters may be specified as for the commands points and text.

Details

The database is searched for all cities matching the specified criteria and fitting within the limits of the plot currently displayed. The default database is of all cities that have a population greater than a certain threshold or which are capital cities of a country or island territory. The threshold varies from country to country, but in general is no higher than about 40,000. The data are copyright Stefan Helders but freely available from his website http://www.world-gazetteer.com.

There are three supplied databases, world.cities (the default), us.cities and canada.cities. The latter two (which need to be made available by using a data() call, include the state or province name with the city name (thanks to John Woodruff jpwoodruff@irisinternet.net for the state and province information).

Note that if the underlying map is "Pacific-centric", i.e. longitudes exceed 180 degrees, and a projection is used, then the map.cities data must be transformed appropriately.

Value

No value is returned from map.cities.

Side Effects

All cities within the boundaries of the plot containing the current map are added to the plot. Note that it is possible that the boundaries of the plot exceed the boundaries of the map requested, and so more cities than were expected might be shown.

See Also

world.cities, canada.cities, us.cities

Examples

map("world", "China")
map.cities(country = "China", capitals = 2)
map("state", "New Jersey")
data(us.cities)
map.cities(us.cities, country="NJ")


Add Scale to Existing Unprojected Map

Description

Adds a scale to an existing map, both as a ratio and a distance gauge.

Usage

map.scale(x, y, relwidth = 0.15, metric = TRUE, ratio = TRUE, ...)

Arguments

x |
y | Location of left end of distance gauge. If not specified, this will be taken to be near the lower left corner of the map.
relwidth | Proportion of width of display to be used for the scale. The default is 0.15 (15%).
metric | If TRUE, the distance gauge will be in km, otherwise miles.
ratio | If FALSE, the scale ratio of the map is not displayed.
... | Further plotting parameters may be specified as for the command text().

Details

The scale is calculated from the displayed graph's plotting parameters, and the latitude of the location at which the distance gauge will be displayed.

Value

The exact calculated scale is returned.

NOTE

This function is meaningful only if no projection= has been specified in the call to map().

Side Effects

A scale is added to the currently displayed map. This takes the form of an approximate 1:n scale (containing 2-3 significant digits), above a distance gauge which is reasonably accurate for the latitude at which it appears. The circumference at the given latitude is interpolated from a radius of 6356.78 km at the pole and 6378.16 km at the equator.

See Also

map.axes

Examples

map("world", "China")
map.scale()


Draw a map with labeled regions

Description

Like map, but labels the regions.

Usage

map.text(database, regions = ".", labels, cex = 0.75, add = FALSE,
move = FALSE, ...)

Arguments

database | character string naming a geographical database, or a list of x, y, and names obtained from a previous call to map.
regions | character vector that names the polygons to draw.
labels | character vector of labels, one for each region. Defaults to the names in the database.
cex | character expansion factor.
add | If FALSE, a map is drawn, then labels placed on top. If TRUE, labels are added to the existing map.
move | If TRUE, labels are moved so that they don't overlap. Requires the mining library (not in CRAN, contact tpminka@media.mit.edu).
... | Other arguments are the same as in map.

Value

If add = FALSE, a map is drawn by calling map. Then the label for each region is placed at the centroid of the region polygon.
The return value is a map object, as from map.

Author(s)

Tom Minka

Examples

map.text("world", "ira")    # iran and iraq
map.text("state", "penn")
map.text("county", "penn")  # Pennsylvania counties
map.text("county", "new jersey")  # New Jersey counties


Locate points on a map

Description

Returns the region names containing given locations.

Usage

map.where(database = "world", x, y)

Arguments

database | character string naming a geographical database, or a list of x, y, and names. See the documentation for map for more details.
x | vector of longitudes.
y | vector of latitudes.

Value

A list of character strings, naming the map region that each (longitude, latitude) pair falls into.

Note

Because maps are currently organized as flat files, this function can be slow.

Author(s)

Tom Minka

See Also

in.polygon

Examples

# NYC
map.where("state", -73.8, 41)
# Auckland
map.where("nz", 174.6, -36.92)
# find both in the world (takes a while)
map.where(x = c(174.6, -73.8), y = c(-36.92, 41))
# with a map object:
m = map("state", "new york", fill = TRUE, plot = FALSE)
map.where(m, -73.8, 41)


Index map regions

Description

Assigns an index to each map region, useful for map coloring.

Usage

match.map(database, regions, exact = FALSE, warn = TRUE)

Arguments

database | character string naming a geographical database, or a map object. See the documentation for map for more details.
regions | a vector of names, or more generally regular expressions to match against the map region names.
exact | If TRUE, only exact matches with regions are considered. Otherwise each element of regions is assumed to be a regular expression. Matches are always case-insensitive.
warn | If TRUE, a warning is printed when an element of regions matches nothing in the map.

Value

Returns an integer vector giving an index to each region in the database. The index is the index of the string in regions which matches the region name. Matching is done as in map. More specifically, all regions r whose name matches regions[i] will have index i. Unmatched regions will have index NA. Overlapping matches cause an error.
This behavior differs from pmatch because a single entry in regions may match several entries in the map.

Author(s)

Tom Minka

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report, 1991. http://www.research.att.com/areas/stat/doc/93.2.ps

See Also

grep

Examples

# filled map showing Republican vote in 1900
# (figure 6 in the reference)
data(state, package = "datasets")
data(votes.repub)
state.to.map <- match.map("state", state.name)
x <- votes.repub[state.to.map, "1900"]
gray.colors <- function(n) gray(rev(0:(n - 1))/n)
color <- gray.colors(100)[floor(x)]
map("state", fill = TRUE, col = color); map("state", add = TRUE)


New Zealand Basic Map

Description

This database produce a map of New Zealand at a basic level of detail. The `"nz"' database includes the 3 main Islands and 19 smaller coastal islands.

Usage

data(nzMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

See Also

map

Examples

map('nz')
map('nz', xlim = c(166, 179), ylim = c(-48, -34))


Sample datasets

Description

Datasets used to illustrate map functions.

Usage

data(ozone)
data(votes.repub)


Polygon functions

Description

These functions are called internally and will generally not be required by the user.

Usage

area.polygon(p)
centroid.polygon(p)
## S3 method for class 'polygon':
as.matrix(x, ...)
closed.polygon(p)
in.one.polygon(p, x)
in.polygon(p, x)
num.polygons(p)
## S3 method for class 'polygon':
range(..., na.rm = FALSE)
sub.polygon(p, i)


Smooth out aggregated data

Description

Increases the resolution of data aggregated over map regions, by either smoothing or interpolation. Also fills in missing values.

Usage

smooth.map(m, z, res = 50, span = 1/10, averages = FALSE, type = c("smooth",
"interp"), merge = FALSE)

Arguments

m | a map object
z | a named vector
res | a vector of length two, specifying the resolution of the sampling grid in each dimension. If a single number, it is taken as the vertical resolution, with double taken as the horizontal resolution.
span | kernel parameter (larger = smoother). span = Inf is a special case which invokes the cubic spline kernel. span is automatically scaled by the map size, and is independent of res.
averages | If TRUE, the values in z are interpreted as averages over the regions. Otherwise they are interpreted as totals.
type | see details.
merge | If TRUE, a region named in z includes all matching regions in the map (according to match.map). If FALSE, a region named in z is assumed to refer to exactly one region on the map.

Details

For type = "smooth", the region totals are first converted into point measurements on the sampling grid, by dividing the total for a region among all sample points inside it. Then it is a regular kernel smoothing problem. Note that the region totals are not preserved.

The prediction zo for location xo (a vector) is the average of z for nearby sample points:

zo = (sum_x k(x, xo) z(x))/(sum_x k(x, xo))

k(x, xo) = exp(-lambda ||x - xo||^2)

lambda is determined from span. Note that xo is over the same sampling grid as x, but zo is not necessarily the same as z(xo).

For type = "interp", the region totals are preserved by the higher-resolution function. The function is assumed to come from a Gaussian process with kernel k. The measurement z[r] is assumed to be the sum of the function over the discrete sample points inside region r. This leads to a simple formula for the covariance matrix of z and the cross-covariance between zo and z. The prediction is the cross-covariance times the inverse covariance times z. Unlike Tobler's method, the predictions are not constrained to live within the original data range, so there tends to be "ringing" effects.

See the references for more details.

Value

A data frame with columns x, y, and z giving the smoothed value z for locations (x, y). Currently the (x, y) values form a grid, but this is not guaranteed in the future.

Author(s)

Tom Minka

References

W.F. Eddy and A. Mockus. An example of the estimation and display of a smoothly varying function of time and space - the incidence of mumps disease. Journal of the American Society for Information Science, 45(9):686-693, 1994. http://www.research.avayalabs.com/user/audris/papers/jasis.pdf

W. R. Tobler. Smooth pycnophylactic interpolation for geographical regions. Journal of the American Statistical Association 74:519-530, 1979.

Examples

# compare to the example for match.map
data(state, package = "datasets")
data(votes.repub)
z = votes.repub[, "1900"]
m = map("state", fill = TRUE, plot = FALSE)
# use a small span to fill in, but not smooth, the data
# increase the resolution to get better results
fit = smooth.map(m, z, span = 1/100, merge = TRUE, ave = TRUE)
mat = tapply(fit$z, fit[1:2], mean)
gray.colors <- function(n) gray(rev(0:(n - 1))/n)
par(bg = "blue")
filled.contour(mat, color.palette = gray.colors, nlev = 32, asp = 1)
# another way to visualize:
image(mat, col = gray.colors(100))

# for a higher degree of smoothing:
# fit = smooth.map(m, z, merge = TRUE, ave = TRUE)
# interpolation, state averages are preserved:
# fit = smooth.map(m, z, merge = TRUE, ave = TRUE, type = "interp")


United States State Boundaries Map

Description

This database produces a map of the states of the United States mainland generated from US Department of the Census data (see the reference).

Usage

data(stateMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

US Department of Commerce, Census Bureau, County Boundary File, computer tape, available from Customer Services, Bureau of the Census, Washingdon DC 20233.

See Also

map.

Examples

map('state', fill = TRUE, col = palette())


Database of US cities

Description

This database is of us cities of population greater than about 40,000. Also included are state capitals of any population size.

Format

A list with 6 components, namely "name", "country.etc", "pop", "lat", "long", and "capital", containing the city name, the state abbreviation, approximate population (as at January 2006), latitude, longitude and capital status indication (0 for non-capital, 1 for capital, 2 for state capital.

NOTE

Some of the city names may be out of date. Please send any corrections to the package maintainer.

See Also

map.cities


United States Coast Map

Description

This database produces a map of the United States mainland generated from US Department of the Census data (see the reference).

Usage

data(usaMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

US Department of Commerce, Census Bureau, County Boundary File, computer tape, available from Customer Services, Bureau of the Census, Washingdon DC 20233.

See Also

map.

Examples

map('usa')


Low resolution World Map

Description

This world database comes from a thinned cleaned-up version of the CIA World Data Bank II data and contains approximately 30,000 points representing the world coastlines and national boundaries. The full database of nearly 2 million points is found in the mapdata package.

Usage

data(worldMapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

Source

The CIA World Data Bank II is currently (mid-2003) available from http://www.evl.uic.edu/pape/data/WDB/.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

See Also

map

Examples

map('world', fill = TRUE, col = 1:10)


Pacific Centric Low resolution World Map

Description

This world database comes from a thinned cleaned-up version of the CIA World Data Bank II data and contains approximately 30,000 points representing the world coastlines and national boundaries. The full database of nearly 2 million points is found in the mapdata package. This map is based on latitudes [0, 360), which then has the Pacific Ocean in the centre of the map.

Usage

data(world2MapEnv)

Format

The data file is merely an assignment to a character string which specifies the name of an environment variable which contains the base location of the binary files used by the map drawing functions. This environment variable (R_MAP_DATA_DIR for the datasets in the maps package) is set at package load time if it does not already exist. Hence setting the environment variable before loading the package can override the default location of the binary datasets.

Source

The CIA World Data Bank II is currently (mid-2003) available from http://www.evl.uic.edu/pape/data/WDB/.

References

Richard A. Becker, and Allan R. Wilks, "Maps in S", AT&T Bell Laboratories Statistics Research Report [93.2], 1993.

Richard A. Becker, and Allan R. Wilks, "Constructing a Geographical Database", AT&T Bell Laboratories Statistics Research Report [95.2], 1995.

See Also

map, world

Examples

map('world2', xlim = c(100, 300))
map.axes()


Database of world cities

Description

This database is primarily of world cities of population greater than about 40,000. Also included are capital cities of any population size, and many smaller towns.

Format

A list with 6 components, namely "name", "country.etc", "pop", "lat", "long", and "capital", containing the city name, the country name, approximate population (as at January 2006), latitude, longitude and capital status indication (0 for non-capital, 1 for capital, 2 for China Municipalities, and 3 for China Provincial capitals)

NOTE

Some of the country names and city names may be out of date. Please send any corrections to the package maintainer.

See Also

map.cities