Delaunay Triangulation and Dirichlet (Voronoi) Tesselation.

Delaunay Triangulation and Dirichlet (Voronoi) Tesselation. [R logo]

Help pages for package `deldir'

deldir | Construct the Delaunay triangulation and the Dirichlet (or Voronoi) tessellation of a planar point set.
plot.deldir | Produce a plot of the Delaunay triangulation and Dirichlet (Voronoi) tesselation of a planar point set, as constructed by the function deldir.
plot.tile.list | Plot Dirchlet/Voronoi tiles
tile.list | Create a list of tiles in a tessellation.


Construct the Delaunay triangulation and the Dirichlet (or Voronoi) tessellation of a planar point set.

Description

This function computes the Delaunay triangulation (and hence the Dirichlet tesselation) of a planar point set according to the second (iterative) algorithm of Lee and Schacter — see REFERENCES. The triangulation is made to be with respect to the whole plane by suspending it from so-called ideal points (-Inf,-Inf), (Inf,-Inf) (Inf,Inf), and (-Inf,Inf). The triangulation is also enclosed in a finite rectangular window. A set of dummy points may be added, in various ways, to the set of data points being triangulated.

Usage

deldir(x, y, dpl=NULL, rw=NULL, eps=1e-09, frac=0.0001,
       sort=TRUE, plotit=FALSE, digits=6, ...)

Arguments

x,y | The coordinates of the point set being triangulated. These can be given by two arguments x and y which are vectors or by a single argument x which is a list with components "x" and "y".
dpl | A list describing the structure of the dummy points to be added to the data being triangulated. The addition of these dummy points is effected by the auxilliary function dumpts(). The list may have components: ndx: The x-dimension of a rectangular grid; if either ndx or ndy is null, no grid is constructed. ndy: The y-dimension of the aforementioned rectangular grid. nrad: The number of radii or "spokes", emanating from each data point, along which dummy points are to be added. nper: The number of dummy points per spoke. fctr: A factor determining the length of each spoke; each spoke is of length equal to fctr times the mean nearest neighbour distance of the data. (This distance is calculated by the auxilliary function mnnd().) x: A vector of x-coordinates of "ad hoc" dummy points y: A vector of the corresponding y-coordinates of "ad hoc" dummy points
rw | The coordinates of the corners of the rectangular window enclosing the triangulation, in the order (xmin, xmax, ymin, ymax). Any data points (including dummy points) outside this window are discarded. If this argument is omitted, it defaults to values given by the range of the data, plus and minus 10 percent.
eps | A value of epsilon used in testing whether a quantity is zero, mainly in the context of whether points are collinear. If anomalous errors arise, it is possible that these may averted by adjusting the value of eps upward or downward.
frac | A value specifying the tolerance used in eliminating duplicate points; defaults to 0.0001. Points are considered duplicates if abs(x1-x2) < frac*(xmax-xmin) AND abs(y1-y2) < frac*(ymax-ymin).
sort | Logical argument; if TRUE (the default) the data (including dummy points) are sorted into a sequence of "bins" prior to triangulation; this makes the algorithm slightly more efficient. Normally one would set sort equal to FALSE only if one wished to observe some of the fine detail of the way in which adding a point to a data set affected the triangulation, and therefore wished to make sure that the point in question was added last. Essentially this argument would get used only in a de-bugging process.
plotit | Logical argument; if TRUE a plot of the triangulation and tessellation is produced; the default is FALSE.
digits | The number of decimal places to which all numeric values in the returned list should be rounded. Defaults to 6.
... | Auxilliary arguments add, wlines, wpoints, number, nex, col, lty, pch, xlim, and ylim (and possibly other plotting parameters) may be passed to plot.deldir through "..." if plotit=TRUE.

Details

This package is a (straightforward) adaptation of the Splus library section ``delaunay'' to R. That library section is an implementation of the Lee-Schacter algorithm, which was originally written as a stand-alone Fortran program in 1987/88 by Rolf Turner, while with the Division of Mathematics and Statistics, CSIRO, Sydney, Australia. It was re-written as an Splus function (using dynamically loaded Fortran code), by Rolf Turner while visiting the University of Western Australia, May, 1995.

Further revisions made December 1996. The author gratefully acknowledges the contributions, assistance, and guidance of Mark Berman, of D.M.S., CSIRO, in collaboration with whom this project was originally undertaken. The author also acknowledges much useful advice from Adrian Baddeley, formerly of D.M.S., CSIRO (now Professor of Statistics at the University of Western Australia). Daryl Tingley of the Department of Mathematics and Statistics, University of New Brunswick provided some helpful insight. Special thanks are extended to Alan Johnson, of the Alaska Fisheries Science Centre, who supplied two data sets which were extremely valuable in tracking down some errors in the code.

Don MacQueen, of Lawrence Livermore National Lab, wrote an Splus driver function for the old stand-alone version of this software. That driver, which was available on Statlib, is now deprecated in favour of the current package ``delaunay'' package. Don also collaborated in the preparation of that package.

Further revisions and bug-fixes were made in 1998, 1999, and 2002.

Value

A list (of class deldir), invisible if plotit=TRUE, with components:

delsgs | a matrix with 6 columns. The first 4 entries of each row are the coordinates of the points joined by an edge of a Delaunay triangle, in the order (x1,y1,x2,y2). The last two entries are the indices of the two points which are joined.
dirsgs | a data frame with 8 columns. The first 4 entries of each row are the coordinates of the endpoints of one the edges of a Dirichlet tile, in the order (x1,y1,x2,y2). The fifth and sixth entries are the indices of the two points, in the set being triangulated, which are separated by that edge. The seventh and eighth entries are logical values. The seventh indicates whether the first endpoint of the corresponding edge of a Dirichlet tile is a boundary point (a point on the boundary of the rectangular window). Likewise for the eighth entry and the second endpoint of the edge.
summary | a matrix with 9 columns, and (n.data + n.dum) rows (see below). These rows correspond to the points in the set being triangulated. The columns are named "x" (the x-coordinate of the point), "y" (the y-coordinate), "n.tri" (the number of Delaunay triangles emanating from the point), "del.area" (1/3 of the total area of all the Delaunay triangles emanating from the point), "del.wts" (the corresponding entry of the "del.area" column divided by the sum of this column), "n.tside" (the number of sides — within the rectangular window — of the Dirichlet tile surrounding the point), "nbpt" (the number of points in which the Dirichlet tile intersects the boundary of the rectangular window), "dir.area" (the area of the Dirichlet tile surrounding the point), and "dir.wts" (the corresponding entry of the "dir.area" column divided by the sum of this column). Note that the factor of 1/3 associated with the del.area column arises because each triangle occurs three times — once for each corner.
n.data | the number of real (as opposed to dummy) points in the set which was triangulated, with any duplicate points eliminated. The first n.data rows of "summary" correspond to real points.
n.dum | the number of dummy points which were added to the set being triangulated, with any duplicate points (including any which duplicate real points) eliminated. The last n.dum rows of "summary" correspond to dummy points.
del.area | the area of the convex hull of the set of points being triangulated, as formed by summing the "del.area" column of "summary".
dir.area | the area of the rectangular window enclosing the points being triangulated, as formed by summing the "dir.area" column of "summary".
rw | the specification of the corners of the rectangular window enclosing the data, in the order (xmin, xmax, ymin, ymax).

Side Effects

If plotit==TRUE a plot of the triangulation and/or tessellation is produced or added to an existing plot.

Note

If ndx >= 2 and ndy >= 2, then the rectangular window IS the convex hull, and so the values of del.area and dir.area are identical.

References

Lee, D. T., and Schacter, B. J. "Two algorithms for constructing a Delaunay triangulation", Int. J. Computer and Information Sciences, Vol. 9, No. 3, 1980, pp. 219 – 242.

Ahuja, N. and Schacter, B. J. (1983). Pattern Models. New York: Wiley.

See Also

plot.deldir

Examples

x   <- c(2.3,3.0,7.0,1.0,3.0,8.0)
y   <- c(2.3,3.0,2.0,5.0,8.0,9.0)
try <- deldir(x,y,list(ndx=2,ndy=2),c(0,10,0,10))
# Puts dummy points at the corners of the rectangular
# window, i.e. at (0,0), (10,0), (10,10), and (0,10)
## Not run:
try <- deldir(x,y,list(ndx=2,ndy=2),c(0,10,0,10),plot=TRUE,wl='tr')
## End(Not run)
# Plots the triangulation which was created (but not the tesselation).
[Package deldir version 0.0-5 Index]


Internal deldir functions

Description

Internal deldir functions.

Usage

dumpts(x,y,dpl,rw)
ind.dup(x,y,rw=NULL,frac=0.0001)
mid.in(x,y,rx,ry)
mnnd(x,y)
get.cnrpt(j,xxx,cntr)

Details

These functions are auxilliary and are not intended to be called by the user.


Produce a plot of the Delaunay triangulation and Dirichlet (Voronoi) tesselation of a planar point set, as constructed by the function deldir.

plot.deldir(deldir) R Documentation

Produce a plot of the Delaunay triangulation and Dirichlet (Voronoi) tesselation of a planar point set as constructed by the function deldir.

Description

This is a method for plot.

Usage

## S3 method for class 'deldir':
plot(x,add=FALSE,wlines=c('both','triang','tess'),
                      wpoints=c('both','real','dummy','none'),
                      number=FALSE,cex=1,nex=1,col=NULL,lty=NULL,
                      pch=NULL,xlim=NULL,ylim=NULL,xlab='x',ylab='y',...)

Arguments

x | An object of class "deldir" as constructed by the function deldir.
add | logical argument; should the plot be added to an existing plot?
wlines | "which lines?". I.e. should the Delaunay triangulation be plotted (wlines='triang'), should the Dirichlet tessellation be plotted (wlines='tess'), or should both be plotted (wlines='both', the default) ?
wpoints | "which points?". I.e. should the real points be plotted (wpoints='real'), should the dummy points be plotted (wpoints='dummy'), should both be plotted (wpoints='both', the default) or should no points be plotted (wpoints='none')?
number | Logical argument, defaulting to FALSE; if TRUE then the points plotted will be labelled with their index numbers (corresponding to the row numbers of the matrix "summary" in the output of deldir).
cex | The value of the character expansion argument cex to be used with the plotting symbols for plotting the points.
nex | The value of the character expansion argument cex to be used by the text function when numbering the points with their indices. Used only if number=TRUE.
col | the colour numbers for plotting the triangulation, the tesselation, the data points, the dummy points, and the point numbers, in that order; defaults to c(1,1,1,1,1). If fewer than five numbers are given, they are recycled. (If more than five numbers are given, the redundant ones are ignored.)
lty | the line type numbers for plotting the triangulation and the tesselation, in that order; defaults to 1:2. If only one value is given it is repeated. (If more than two numbers are given, the redundant ones are ignored.)
pch | the plotting symbols for plotting the data points and the dummy points, in that order; may be either integer or character; defaults to 1:2. If only one value is given it is repeated. (If more than two values are given, the redundant ones are ignored.)
xlim | the limits on the x-axis. Defaults to rw[1:2] where rw is the rectangular window specification returned by deldir().
ylim | the limits on the y-axis. Defaults to rw[3:4] where rw is the rectangular window specification returned by deldir().
xlab | label for the x-axis. Defaults to x. Ignored if add=TRUE.
ylab | label for the y-axis. Defaults to y. Ignored if add=TRUE.
... | Further plotting parameters to be passed to plot() segments() or points(). Unlikely to be used.

Details

The points in the set being triangulated are plotted with distinguishing symbols. By default the real points are plotted as circles (pch=1) and the dummy points are plotted as triangles (pch=2).

Side Effects

A plot of the points being triangulated is produced or added to an existing plot. As well, the edges of the Delaunay triangles and/or of the Dirichlet tiles are plotted. By default the triangles are plotted with solid lines (lty=1) and the tiles with dotted lines (lty=2).

See Also

deldir

Examples

## Not run:
try <- deldir(x,y,list(ndx=2,ndy=2),c(0,10,0,10))
plot(try)
#
deldir(x,y,list(ndx=4,ndy=4),plot=TRUE,add=TRUE,wl='te',
       col=c(1,1,2,3,4),num=TRUE)
# Plots the tesselation, but does not save the results.
try <- deldir(x,y,list(ndx=2,ndy=2),c(0,10,0,10),plot=TRUE,wl='tr',
              wp='n')
# Plots the triangulation, but not the points, and saves the returned
structure.
## End(Not run)


Plot Dirchlet/Voronoi tiles

Description

A method for plot. Plots (sequentially) the tiles associated with each point in the set being tessellated.

Usage

plot.tile.list(x, verbose = FALSE, close=FALSE, pch=1, polycol=NA,
               showpoints=TRUE, ...)
## S3 method for class 'tile.list':
plot(x, verbose = FALSE, close=FALSE, pch=1,
                         polycol=NA, showpoints=TRUE, ...)

Arguments

x | A list of the tiles in a tessellation, as produced the function tile.list().
verbose | Logical scalar; if TRUE the tiles are plotted one at a time (with a ``Go?'' prompt after each) so that the process can be watched.
close | Logical scalar; if TRUE the outer edges of of the tiles (i.e. the edges of the enclosing rectangle) are drawn. Otherwise tiles on the periphery of the tessellation are left ``open''.
pch | The plotting character for plotting the points of the pattern which was tessellated. Ignored if showpoints is FALSE.
polycol | Optional vector of integers (or NAs); the i-th entry indicates with which colour to fill the i-th tile. Note that an NA indicates the use of no colour at all.
showpoints | Logical scalar; if TRUE the points of the pattern which was tesselated are plotted.
... | Optional arguments; not used. There for consistency with the generic plot function.

Value

NULL; side effect is a plot.

Warning

The default value for verbose was formerly TRUE; it is now FALSE.

Author(s)

Rolf Turner

See Also

tile.list()

Examples

        x <- runif(20)
        y <- runif(20)
        z <- deldir(x,y,rw=c(0,1,0,1))
        w <- tile.list(z)
        plot(w)
        ccc <- rep(2:5,5)
        plot(w,polycol=ccc,close=TRUE)


Create a list of tiles in a tessellation.

Description

For each point in the set being tessellated produces a list entry describing the Dirichlet/Voronoi tile containing that point.

Usage

 tile.list(object)

Arguments

object An object of class deldir as produced by the function deldir().

Value

A list with one entry for each of the points in the set being tesselated. Each entry is in turn a list with components

pt | The coordinates of the point whose tile is being described.
x | The x coordinates of the vertices of the tile, in anticlockwise order.
y | The y coordinates of the vertices of the tile, in anticlockwise order.
bp | Vector of logicals indicating whether the tile vertex is a ``real'' vertex, or a boundary point, i.e. a point where the tile edge intersects the boundary of the enclosing rectangle

Warning

The set of vertices of each tile may be ``incomplete''. Only vertices which lie within the enclosing rectangle, and ``boundary points'' are listed.

Note that the enclosing rectangle may be specified by the user in the call to deldir().

In contrast to the previous version of deldir, the corners of the enclosing rectangle are now include as vertices of tiles. I.e. a tile which in fact extends beyond the rectangular window and contains a corner of that window will have that corner added to its list of vertices. Thus when the corresponding polygon is plotted, the result is the intersection of the tile with the enclosing rectangular window.

Author(s)

Rolf Turner

See Also

deldir(), plot.tile.list()

Examples

        x <- runif(20)
        y <- runif(20)
        z <- deldir(x,y)
        w <- tile.list(z)

        z <- deldir(x,y,rw=c(0,1,0,1))
        w <- tile.list(z)

        z <- deldir(x,y,rw=c(0,1,0,1),dpl=list(ndx=2,ndy=2))
        w <- tile.list(z)